fbpx
Delivery as normal through November lockdown.
Ride On Toys – Knowledge Base

How can we help?

You can search our knowledge base to find answers to the most common questions.

Popular Categories: OverviewArticle PagesFAQs

Troubleshooting For Ride On’s

You are here:
< All Topics

In all cases we ask that you inspect your goods within 48 Hours of receipt, after this period we deem that you have accepted the goods, However, should you inspect the goods and find there is damage you must report any damages to us by email immediately and within the 48 hour window from delivery. Please photograph the damage of the product in the box as you find it. Once you have found the item to be damaged, Do not continue to assemble your item, otherwise we will assume you have accepted it and may ask you to prove that you haven’t damaged the item, Once you spot any damage that means you would like to return the item simply repackage it into its original packaging with all accessories and follow the returns criteria below.

 Has the toy worked at all since it has arrived?

–   Ride On Toys usually come with a charge and will normally work straight out of the box but it’s not gospel so if the toy isn’t working out of the box and you are happy the batteries are connected properly please charge the toy for a minimum for 6 hours before contacting us.

When you charged the toy did you put it on charge for the recommended amount of time?

Please refer to the cars user manual for the time to charge they normally range between 4 and 8 hours and its first charge is vital as the first charge conditions the battery for its life cycle.

Did The Charger Get Warm Whilst Charging?

–   It’s completely normal for a charger to get warm whilst charging. However if you are finding that the charger isn’t getting warm at all this is a sure sign that the charger is faulty and we may need to look at replacing it. 

Are Certain Parts Of The Ride On Toy Working But Not Others?

 If you are seeing that certain parts of the kids ride on toy are working but other aspects are not working it’s normally that a wire has come loose somewhere – please check all the connections under the car, motors, and in the battery box. 

The Lights and sounds work but the ride on toy motors are not getting any power. Do you hear a clicking sound from the wheels?

–   So a clicking sound from the motor can be one of two things whether the car has been overloaded either with weight or terrain or one of the wires to the motors have come loose and not getting a connection – If you think it’s been overloaded allow the motors to cool down and come back to it. If it’s definitely not overloading then you need to check all motor connections.

The Ride On Toy Will Work With The Remote Control But Not With The Pedal?

– In the rare occasion this happens you will find it’s the switch under the foot pedal, these are easily replaceable please call us and we will advise. .

I Can’t Get The Parental Remote Control To Pair?

–   So your remote control has lost its sync with the car… No Problems follow these instructions exactly and you will be back up and running. 

1. Turn The Car Off 

2. Hold Down Forward and Reverse On The Remote ( Do Not Let Go Until The End Of This Sequence )

3. Turn the car on. 

4. Watch the remote flash for about a minute. Then it will stop flashing …. Then it will start again. When the second sequence of flashes stops. 

5. Let go of forward and reverse. 

6. Press Forward 

7. Press Reverse. 

Your car is now working again with the remote Control! 

Im TryingTo Go Forward But The Car Is Going Backwards…

  • If the car reverses when it should go forwards– the motor wires simply need to be swapped over.

My ride On Is Sluggish Or Slow

 These toys have a maximum weight limit they can carry and may stop operating if this is passed. Other conditions that may hinder the cars ability are long thick grass, too steep an incline, sand etc. Any combination of these conditions may overload the vehicle. The best surface to use these vehicles is a flat clear tarmacked area

  • The fuse may need replacing, this can be checked with a multi-meter and is usually housed in a small box, attached to the lead that goes from the battery to the main control box.

Theres’s A Clicking Sound Coming From The Motors But The Car Won’t Move

  • This could mean that the motors are not sitting correctly inside the wheels, check that the cog part of the motor is fitted correctly inside the wheel.

My Ride On Has No Power Or Cuts Out After A Few Seconds Of Use But The Charger Is Working Correctly And The Batteries Are Ok..

  • The fuse may be faulty, this can be checked with a multi-meter and is usually housed in a small box, attached to the lead that goes from the battery to the main control box.
  • Also if the toy is misused and you exceed the maximum weight guide, the fuse will cut out and reset after 30 seconds or so, this can make it seem like the toy is faulty but it is a safety measure to stop the toy from sustaining damage by being used when overloaded

Still Need Help With My Ride On Toy Car

Once you have check all of the above and not found the solutions then email us via [email protected]

What helps us and saves you time is emailing us with the following. 

1. The name as it appeared on your order 

2. Your Order Number

3. Pictures of the wiring of the Ride on Toy

4. Pictures of the problem area. 

Once we have this information we will come back to you with suggestions or a solution. 

It’s likely if you call we will refer you to this document and ask you to check as 90% of all customers’ issues are fixed with the above.

Previous Troubleshooting For Petrol Quads And Dirt Bikes
Next Troubleshooting For Two Strokes
Was this article helpful?
0 out of 5 stars
5 Stars 0%
4 Stars 0%
3 Stars 0%
2 Stars 0%
1 Stars 0%
How can we improve this article?
Table of Contents
Back To Top